Устанавливаю драйвера для "Kyocera M5526cdw"

Обмен опытом по установке Линукс на разные аппаратные конфигурации

Модераторы: Olej, vikos

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 15:18

Драйвера для установки скачивал с официального сайта:
Linux Universal Driver (Phase9_20220203)
SANE Driver (2.0.0326)

Код: Выделить всё

root@wn10:/media/user/KINGSTON/KYOCERA ECOSYS M5526cdw/Linux_Universal_Driver_Phase9_20220203/KyoceraLinuxPackages-20220203/Debian/Global/kyodialog_amd64# dpkg -i kyodialog_9.1-0_amd64.deb
Выбор ранее не выбранного пакета kyodialog.
(Чтение базы данных … на данный момент установлено 147397 файлов и каталогов.)
Подготовка к распаковке kyodialog_9.1-0_amd64.deb …
Распаковывается kyodialog (9.1-0) …
dpkg: зависимости пакетов не позволяют настроить пакет kyodialog:
 kyodialog зависит от libcupsimage2, однако:
  Пакет libcupsimage2 не установлен.
 kyodialog зависит от python3-setuptools, однако:
  Пакет python3-setuptools не установлен.

dpkg: ошибка при обработке пакета kyodialog (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для dbus (1.12.20-2+astra.se7+ci4) …
Обрабатываются триггеры для xserver-xorg-core (2:1.20.11-1ubuntu1astra.se6) …
update exec ids due to /usr/bin changed
Обрабатываются триггеры для desktop-file-utils (0.26-1astra1) …
Обрабатываются триггеры для mime-support (3.62) …
При обработке следующих пакетов произошли ошибки:
 kyodialog
root@wn10:/media/user/KINGSTON/KYOCERA ECOSYS M5526cdw/Linux_Universal_Driver_Phase9_20220203/KyoceraLinuxPackages-20220203/Debian/Global/kyodialog_amd64#
Не хватает 2х пакетов:
- libcupsimage2
- python3-setuptools

Монтирую загрузочную флешку, ибо по крайней мере "libcupsimage2" там имеется...
Последний раз редактировалось bellic 09 сен 2022, 11:13, всего редактировалось 2 раза.

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 15:33

Код: Выделить всё

root@wn10:/home/user/Загрузки/Pantum# apt install libcupsimage2
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kyodialog : Зависит: python3-setuptools но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
root@wn10:/home/user/Загрузки/Pantum# apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libcupsimage2 python3-distutils python3-lib2to3 python3-pkg-resources python3-setuptools
Предлагаемые пакеты:
  python-setuptools-doc
Следующие НОВЫЕ пакеты будут установлены:
  libcupsimage2 python3-distutils python3-lib2to3 python3-pkg-resources python3-setuptools
Обновлено 0 пакетов, установлено 5 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
Необходимо скачать 0 B/802 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 3 137 kB.
Хотите продолжить? [Д/н] Д
Пол:1 file:/mnt 1.7_x86-64/main amd64 libcupsimage2 amd64 2.3.3-3astra.se18 [124 kB]
Пол:2 file:/mnt 1.7_x86-64/main amd64 python3-pkg-resources all 40.8.0-1 [153 kB]
Пол:3 file:/mnt 1.7_x86-64/main amd64 python3-lib2to3 all 3.7.3-1 [76,9 kB]
Пол:4 file:/mnt 1.7_x86-64/main amd64 python3-distutils all 3.7.3-1 [142 kB]
Пол:5 file:/mnt 1.7_x86-64/main amd64 python3-setuptools all 40.8.0-1 [306 kB]
Выбор ранее не выбранного пакета libcupsimage2:amd64.
(Чтение базы данных … на данный момент установлено 147814 файлов и каталогов.)
Подготовка к распаковке …/libcupsimage2_2.3.3-3astra.se18_amd64.deb …
Распаковывается libcupsimage2:amd64 (2.3.3-3astra.se18) …
Выбор ранее не выбранного пакета python3-pkg-resources.
Подготовка к распаковке …/python3-pkg-resources_40.8.0-1_all.deb …
Распаковывается python3-pkg-resources (40.8.0-1) …
Выбор ранее не выбранного пакета python3-lib2to3.
Подготовка к распаковке …/python3-lib2to3_3.7.3-1_all.deb …
Распаковывается python3-lib2to3 (3.7.3-1) …
Выбор ранее не выбранного пакета python3-distutils.
Подготовка к распаковке …/python3-distutils_3.7.3-1_all.deb …
Распаковывается python3-distutils (3.7.3-1) …
Выбор ранее не выбранного пакета python3-setuptools.
Подготовка к распаковке …/python3-setuptools_40.8.0-1_all.deb …
Распаковывается python3-setuptools (40.8.0-1) …
Настраивается пакет python3-pkg-resources (40.8.0-1) …
Настраивается пакет libcupsimage2:amd64 (2.3.3-3astra.se18) …
Настраивается пакет python3-lib2to3 (3.7.3-1) …
Настраивается пакет python3-distutils (3.7.3-1) …
Настраивается пакет python3-setuptools (40.8.0-1) …
Настраивается пакет kyodialog (9.1-0) …
running install
running bdist_egg
running egg_info
creating PyPDF3.egg-info
writing PyPDF3.egg-info/PKG-INFO
writing dependency_links to PyPDF3.egg-info/dependency_links.txt
writing top-level names to PyPDF3.egg-info/top_level.txt
writing manifest file 'PyPDF3.egg-info/SOURCES.txt'
reading manifest file 'PyPDF3.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'PyPDF3.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib
creating build/lib/PyPDF3
copying PyPDF3/utils.py -> build/lib/PyPDF3
copying PyPDF3/filters.py -> build/lib/PyPDF3
copying PyPDF3/pagerange.py -> build/lib/PyPDF3
copying PyPDF3/xmp.py -> build/lib/PyPDF3
copying PyPDF3/_version.py -> build/lib/PyPDF3
copying PyPDF3/generic.py -> build/lib/PyPDF3
copying PyPDF3/merger.py -> build/lib/PyPDF3
copying PyPDF3/pdf.py -> build/lib/PyPDF3
copying PyPDF3/__init__.py -> build/lib/PyPDF3
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/utils.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/filters.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/pagerange.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/xmp.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/_version.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/generic.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/merger.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/pdf.py -> build/bdist.linux-x86_64/egg/PyPDF3
copying build/lib/PyPDF3/__init__.py -> build/bdist.linux-x86_64/egg/PyPDF3
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/utils.py to utils.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/filters.py to filters.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/pagerange.py to pagerange.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/xmp.py to xmp.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/_version.py to _version.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/generic.py to generic.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/merger.py to merger.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/pdf.py to pdf.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/PyPDF3/__init__.py to __init__.cpython-37.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying PyPDF3.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying PyPDF3.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying PyPDF3.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying PyPDF3.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/PyPDF3-0.0.1-py3.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing PyPDF3-0.0.1-py3.7.egg
Copying PyPDF3-0.0.1-py3.7.egg to /usr/local/lib/python3.7/dist-packages
Adding PyPDF3 0.0.1 to easy-install.pth file

Installed /usr/local/lib/python3.7/dist-packages/PyPDF3-0.0.1-py3.7.egg
Processing dependencies for PyPDF3==0.0.1
Finished processing dependencies for PyPDF3==0.0.1

You may need to restart dbus for full functionality.

Обрабатываются триггеры для libc-bin (2.28-10+ci202012301235+astra1) …
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-user'
Обрабатываются триггеры для dbus (1.12.20-2+astra.se7+ci4) …
root@wn10:/home/user/Загрузки/Pantum# 

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 15:34

Код: Выделить всё

root@wn10:/home/user/Загрузки/Pantum# apt install libcupsimage2
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет libcupsimage2 самой новой версии (2.3.3-3astra.se18).
libcupsimage2 помечен как установленный вручную.
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
root@wn10:/home/user/Загрузки/Pantum# 

Код: Выделить всё

root@wn10:/home/user/Загрузки/Pantum# apt install python3-setuptools
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет python3-setuptools самой новой версии (40.8.0-1).
python3-setuptools помечен как установленный вручную.
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
root@wn10:/home/user/Загрузки/Pantum# 

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 15:40

Два необходимых пакета благополучно установлены с дистрибутива, можно вернуться к Кюосере:

Код: Выделить всё

root@wn10:/home/user/Загрузки/Pantum# dpkg -i kyodialog_9.1-0_amd64.deb
(Чтение базы данных … на данный момент установлено 148073 файла и каталога.)
Подготовка к распаковке kyodialog_9.1-0_amd64.deb …
Распаковывается kyodialog (9.1-0) на замену (9.1-0) …
/var/lib/dpkg/info/kyodialog.postrm: строка 95: return: возврат можно выполнить только из функции или исходного скрипта
dpkg: предупреждение: old kyodialog package post-removal script subprocess returned error exit status 1
dpkg: попытка использовать сценарий из нового пакета …
/var/lib/dpkg/tmp.ci/postrm: строка 95: return: возврат можно выполнить только из функции или исходного скрипта
dpkg: ошибка при обработке архива kyodialog_9.1-0_amd64.deb (--install):
 new kyodialog package post-removal script subprocess returned error exit status 1
/var/lib/dpkg/tmp.ci/postrm: строка 95: return: возврат можно выполнить только из функции или исходного скрипта
dpkg: error while cleaning up:
 new kyodialog package post-removal script subprocess returned error exit status 1
Обрабатываются триггеры для dbus (1.12.20-2+astra.se7+ci4) …
Обрабатываются триггеры для xserver-xorg-core (2:1.20.11-1ubuntu1astra.se6) …
update exec ids due to /usr/bin changed
Обрабатываются триггеры для desktop-file-utils (0.26-1astra1) …
Обрабатываются триггеры для mime-support (3.62) …
При обработке следующих пакетов произошли ошибки:
 kyodialog_9.1-0_amd64.deb
root@wn10:/home/user/Загрузки/Pantum# 
dpkg: error while cleaning up

Нет такого пути у меня, тем более 95-й строки.... /var/lib/dpkg/tmp.ci/postrm

Нифига не пойму - что ей надо то? :shock: :evil: :twisted: :roll:

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 16:11

Код: Выделить всё

/var/lib/dpkg/info/kyodialog.postrm: строка 95: return: возврат можно выполнить только из функции или исходного скрипта
В строке 95 стоит :
return 0

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 16:28

Есть аналогичный пакет для Ubuntu...
Может попробовать его тогда поставить?
Последний раз редактировалось bellic 09 сен 2022, 11:14, всего редактировалось 1 раз.

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 16:43

Открыл Synaptic, а тут вот такое:
Screenshot_20220908_163718.jpeg
Screenshot_20220908_163718.jpeg (35.37 КБ) 200 просмотров
И что интересно - после закрытия этого сообщения, закрывается и сам Synaptic! :oops:

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 17:13

Код: Выделить всё

root@wn10:/home/user/Загрузки/Pantum# dpkg -s kyodialog
Package: kyodialog
Status: install reinstreq half-installed
Priority: extra
Section: default
Installed-Size: 92861
Maintainer: DriverSupport@ddp.kyocera.com
Architecture: amd64
Version: 9.1-0
Config-Version: 9.1-0
Depends: libcups2, libcupsimage2, cups-filters, libkrb5-3, python3, python3-reportlab, python3-setuptools, libqt5gui5
Conffiles:
 /etc/dbus-1/system.d/com.kyocera.knm.conf c78a03a514826b54d002fe072a9c7d75
 /etc/xdg/autostart/knmd.desktop 51d3910e9462b0e4a530908d84e93150
Description: Kyocera Printing Package
License: unknown
Vendor: Kyocera
Homepage: http://example.com/no-uri-given
root@wn10:/home/user/Загрузки/Pantum# 

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 17:41

# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Пакет kyodialog нуждается в переустановке, но найти архив для него не удалось.

Аватара пользователя
bellic
Писатель
Сообщения: 140
Зарегистрирован: 02 сен 2022, 14:41
Откуда: Ростов-на-Дону
Контактная информация:

Re: Устанавливаю драйвера для "Kyocera M5526cdw"

Непрочитанное сообщение bellic » 08 сен 2022, 17:45

Код: Выделить всё

# dpkg -P kyodialog
dpkg: ошибка при обработке пакета kyodialog (--purge):
 пакет абсолютно неработоспособен; перед попыткой удаления
 его следует переустановить
При обработке следующих пакетов произошли ошибки:
 kyodialog
root@wn10:/home/user/Загрузки/Pantum# dpkg -r kyodialog
dpkg: ошибка при обработке пакета kyodialog (--remove):
 пакет абсолютно неработоспособен; перед попыткой удаления
 его следует переустановить
При обработке следующих пакетов произошли ошибки:
 kyodialog
root@wn10:/home/user/Загрузки/Pantum#

Ответить

Вернуться в «Железо для Linux»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость