OpenWRT x86

встраиваемые модели

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 28 июл 2020, 20:04

Olej писал(а):
24 июл 2020, 21:29
Для меня проблемы - в WiFi, в моём случае в нетбук воткнули 2 разных PCI-E WiFi модулей:
Поменяли WIFi PCI-E адаптеры на более навороченные. Вот такое чудо Atheros AR5B95 802.11b/g/n Wireless PCIe Half AR9285 Lite-on WN6601AH:
Изображение
И вот такое, снятое вообще с Apple Computer ноутбука, неизвестного происхождения:
изображение_viber_2020-07-28_16-10-13.jpg
(как показало последующее выяснение - это тоже Atheros AR5BXB72).

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 28 июл 2020, 20:08

Нужно искать для них модули драйверов...
Olej писал(а):
24 июл 2020, 21:29
Таким образом их можно легко отобрать и установить:

Код: Выделить всё

root@OpenWrt:~# opkg find kmod-* | grep Ather
kmod-ath - 4.14.180+4.19.120-1-1 - This module contains some common parts needed by Atheros Wireless drivers.
kmod-ath10k - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on Atheros IEEE 802.11ac family of chipsets. For now only PCI is supported.
kmod-ath5k - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on Atheros 5xxx chipset.
kmod-ath6kl - 4.14.180+4.19.120-1-1 - Atheros FullMAC wireless devices (common code for ath6kl_sdio and ath6kl_usb)
kmod-ath6kl-sdio - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on Atheros IEEE 802.11n AR6003 and AR6004 family of chipsets.
kmod-ath6kl-usb - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on the Atheros IEEE 802.11n AR6004 chipset.
kmod-ath9k - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.
kmod-ath9k-common - 4.14.180+4.19.120-1-1 - Atheros 802.11n wireless devices (common code for ath9k and ath9k_htc)
kmod-ath9k-htc - 4.14.180+4.19.120-1-1 - This module adds support for wireless adapters based on Atheros USB AR9271 and AR7010 family of chipsets.
kmod-atl1 - 4.14.180-1 - Atheros L1 Gigabit Ethernet support
kmod-atl1c - 4.14.180-1 - Atheros L1C
kmod-atl1e - 4.14.180-1 - Atheros L1E
kmod-atl2 - 4.14.180-1 - Atheros L2 Fast Ethernet support
kmod-carl9170 - 4.14.180+4.19.120-1-1 - Driver for Atheros AR9170 USB sticks
kmod-owl-loader - 4.14.180-1 - Kernel module that helps to initialize certain Qualcomm Atheros' PCI(e) Wifi chips, which have the init data (which contains the PCI device ID for example) stored together with the calibration data in the file system.  This is necessary for devices like the Cisco Meraki Z1.

Код: Выделить всё

root@OpenWrt:~$ opkg find kmod-* | grep Qual
kmod-owl-loader - 4.14.180-1 - Kernel module that helps to initialize certain Qualcomm Atheros' PCI(e) Wifi chips, which have the init data (which contains the PCI device ID for example) stored together with the calibration data in the file system.  This is necessary for devices like the Cisco Meraki Z1.
kmod-usb-net-qmi-wwan - 4.14.180-1 - QMI WWAN driver for Qualcomm MSM based 3G and LTE modems
kmod-usb-serial-qualcomm - 4.14.180-1 - Kernel support for Qualcomm USB Serial devices (Gobi)

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 28 июл 2020, 20:15

Olej писал(а):
28 июл 2020, 20:08
Нужно искать для них модули драйверов...
В конечном итоге, методом проб и ошибок (добавляя новые - может что-то и лишнее) установил:

Код: Выделить всё

root@OpenWrt:~# opkg install kmod-ath kmod-ath10k kmod-ath9k-htc kmod-ath9k-common
...
Configuring kmod-usb-core.
Configuring kmod-ath.
Configuring kmod-ath10k.
Configuring ath9k-htc-firmware.
Configuring kmod-ath9k-common.
Configuring kmod-ath9k-htc.

Код: Выделить всё

root@OpenWrt:~$ opkg install kmod-owl-loader
Installing kmod-owl-loader (4.14.180-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/x86/generic/packages/kmod-owl-loader_4.14.180-1_i386_pentium4.ipk
Configuring kmod-owl-loader.

Код: Выделить всё

root@OpenWrt:~# opkg install kmod-ath9k
Installing kmod-ath9k (4.14.180+4.19.120-1-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/x86/generic/packages/kmod-ath9k_4.14.180%2b4.19.120-1-1_i386_pent
Configuring kmod-ath9k.
И вот после последней установки:

Код: Выделить всё

root@OpenWrt:~# opkg list-installed | grep ath
ath9k-htc-firmware - 20190416-1
kmod-ath - 4.14.180+4.19.120-1-1
kmod-ath10k - 4.14.180+4.19.120-1-1
kmod-ath5k - 4.14.180+4.19.120-1-1
kmod-ath9k - 4.14.180+4.19.120-1-1
kmod-ath9k-common - 4.14.180+4.19.120-1-1
kmod-ath9k-htc - 4.14.180+4.19.120-1-1
Получаем нужные интерфейсы:

Код: Выделить всё

root@OpenWrt:~# iwconfig
eth0      no wireless extensions.

teql0     no wireless extensions.

ifb0      no wireless extensions.

ifb1      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=19 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

wlan1     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=17 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

br-lan    no wireless extensions.

lo        no wireless extensions.

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 28 июл 2020, 20:28

Olej писал(а):
28 июл 2020, 20:15
Получаем нужные интерфейсы:
После настройки (предварительной) через WEB-интерфейс - смотрим что он там прописал в конфигурациях сети:

Код: Выделить всё

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
          
config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option gateway '192.168.1.3'
    list dns '192.168.1.3'
    list dns '217.21.51.1'
    list dns '213.184.232.33'

config interface 'WWAN1'
    option proto 'static'
    option ifname 'wlan0'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'

config interface 'WWAN2'
    option proto 'static'
    option ifname 'wlan1'
    option ipaddr '192.168.3.1'
    option netmask '255.255.255.0'
В WEB настройках выглядит это как-то так:
Вложения
Снимок экрана от 2020-07-28 21-14-41.png

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 28 июл 2020, 20:31

И с отдельного ноутбука (чувствительный приёмник WiFi) ищем доступные точки доступа:

Код: Выделить всё

[olej@DELL ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 5c:26:0a:03:73:e9 brd ff:ff:ff:ff:ff:ff
    altname enp0s25
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 58:94:6b:19:ef:28 brd ff:ff:ff:ff:ff:ff

Код: Выделить всё

[olej@DELL ~]$ sudo iw dev wlp3s0 scan ssid | egrep "SSID|signal"
	signal: -73.00 dBm
	SSID: TP-LINK_VOLS
	signal: -46.00 dBm
	SSID: OpenWrt2
		 * UTF-8 SSID
	signal: -57.00 dBm
	SSID: OpenWrt1
		 * UTF-8 SSID
	signal: -83.00 dBm
	SSID: DIR-300NRUB6
	signal: -86.00 dBm
	SSID: W8101G
	signal: -85.00 dBm
	SSID: W8101G
	signal: -88.00 dBm
	SSID: TP-LINK_BA50D6
	signal: -89.00 dBm
	SSID: netis_2B7178
Проверено, что к каждой из точек доступа, OpenWrt1 & OpenWrt2, можно подключиться и смотреть видео-ролики из Интернет.

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 29 июл 2020, 14:17

Очень информативный и активный русскоязычный форум на 4PDA относительно OpenWRT:
Изображение
Там 247 страниц форумного обсуждения, начиная где-то с 01.08.18 ... пересмотреть даже бегло всё сложно (а нужно ли?) ... но можно найти полезные ответы на свои проблемы.
Но самое ценное: там можно задавать свой вопрос, и в течении 3-4 минут уж начнутся ответы... ;-)

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 29 июл 2020, 14:44

Olej писал(а):
29 июл 2020, 14:17
Очень информативный и активный русскоязычный форум на 4PDA относительно OpenWRT:
Olej писал(а):
28 июл 2020, 20:04
Поменяли WIFi PCI-E адаптеры на более навороченные. Вот такое чудо Atheros...
После установки pciutils (что в OpenWRT по дефаулту не предусмотрено) легко уточнить "на впредь" типы оборудования:

Код: Выделить всё

root@OpenWrt:~# lspci | grep Atheros
0b:00.0 Network controller: Qualcomm Atheros AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) (rev 01)
0c:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Код: Выделить всё

root@OpenWrt:~# lspci -n | grep 168c
0b:00.0 0280: 168c:0024 (rev 01)
0c:00.0 0280: 168c:002b (rev 01)

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 21 авг 2020, 18:31

Olej писал(а):
24 июл 2020, 21:02
Конспектирую для себя ключевые затыки где я потерял время на разборки... (может кому ещё пригодится)
Мои "потребители" от большого ума шаловливыми ручками уничтожили всё, что я добился для них неделей работы ... им захотелось i86 систему только не 32-бит, а 64-бит... На вопрос: "Зачем вам на тупом роутере 64-битный Linux?" - невнятное мычание ... "Абы було". :lol:
Но необычность ситуации в том, что в этой свеже установленной системе нет физического сетевого интерфейса eth0 ... порт Ethernet просто не стартует, зелёный фонарь не горит возле разъёма RG-45 (ноутбука), он физически не работает...

Но теперь есть интерес с более-менее пониманием вопроса пройти всё с начала (в единственный и последний раз, естественно :twisted: ).

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 23 авг 2020, 19:26

Olej писал(а):
21 авг 2020, 18:31
теперь есть интерес с более-менее пониманием вопроса пройти всё с начала
Olej писал(а):
24 июл 2020, 20:46
Как и где взять x86 образ *.img, как его подготовить и записать на флешку - всё описано здесь: OpenWRT. Я использовал 32-бит образ, а не 64-бит.
Небольшие уточнения по ходу...
Скачиваю здесь: Index of (root) / releases / 19.07.3 / targets / x86 / generic /
Здесь есть несколько образов, из которых интерес для меня представляют 2:

Код: Выделить всё

combined-ext4.img.gz	2c2f752ec578f908b9bb0be6484a6aa6913b777fb40352c99e10adb2c034f32d	8218.3 KB	Sun May 17 15:41:08 2020
combined-squashfs.img.gz	0927ee71c4e8f5acda7f9dcafca92e271d536e068e446161dee5a931031dabed	7094.1 KB	Sun May 17 15:41:04 2020
...
2-й из них создаст образ со сжатой файловой системой squashfs - будет немного экономичнее + с особенностями записи поверх существующих данных при обновлениях, мне это не сильно нужно, поэтому я пользуюсь образом для создания традиционной Linux файловой системы ext4 (как по мне, и ext2 было бы более чем достаточно).

Код: Выделить всё

olej@nvidia:~/Загрузки/ISO/OpenWRT$ ls -l openwrt-19.07.3-x86-generic-combined-ext4.img.gz 
-rw-rw-r-- 1 olej olej 8415571 июл 23 12:28 openwrt-19.07.3-x86-generic-combined-ext4.img.gz

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT x86

Непрочитанное сообщение Olej » 31 авг 2020, 17:41

Olej писал(а):
23 авг 2020, 19:26
Небольшие уточнения по ходу...
Разархивировал:

Код: Выделить всё

olej@nvidia:~/2020_WORK$ gunzip openwrt-19.07.3-x86-generic-combined-ext4.img.gz 

olej@nvidia:~/2020_WORK$ ls -l openwrt-19.07.3-x86-generic-combined-ext4.img 
-rw-rw-r-- 1 olej olej 285736960 июл 23 12:28 openwrt-19.07.3-x86-generic-combined-ext4.img
Записать на флешку - создать загрузочную флешку...
Можно бы традиционно:

Код: Выделить всё

# dd if=openwrt-19.07.3-x86-generic-combined-ext4.img of=/dev/sda 
Но я это сделал программой balenaEtcher (см. здесь):
Изображение
Теперь у нас есть загрузочная флешка - на все виды инсталляций!

Ответить

Вернуться в «Одноплатные компьютеры»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость