OpenWRT

встраиваемые модели

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 17:22

Olej писал(а):
23 июл 2020, 17:33
После перезагрузки и возобновления сессии SSH - обновление пакетной системы:

Код: Выделить всё

root@OpenWrt:~# time opkg update
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/x86/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
...
Это особенность пакетной системы opkg - все кэши и обновление оно хранит в файловой системе tmpfs, при перезагрузке всё теряется ... это достаточно разумное решение для ОС роутеров.
Пакеты в репозитории достаточно плотно обновляются - несколько дней и:

Код: Выделить всё

root@OpenWrt:/etc/init.d$ opkg list-upgradable
luci-app-opkg - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
rpcd - 2019-12-10-aaa08366-2 - 2020-05-26-67c8a3fd-1
busybox - 1.30.1-5 - 1.30.1-6
luci-lib-ip - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci-mod-system - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci-theme-bootstrap - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
libuclient20160123 - 2019-05-30-3b3e368d-1 - 2020-06-17-51e16ebf-1
luci-mod-status - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
firewall - 2019-11-22-8174814a-1 - 2019-11-22-8174814a-2
luci-app-firewall - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
uclient-fetch - 2019-05-30-3b3e368d-1 - 2020-06-17-51e16ebf-1
libubox20191228 - 2020-02-27-7da66430-1 - 2020-05-25-66195aee-1
rpcd-mod-file - 2019-12-10-aaa08366-2 - 2020-05-26-67c8a3fd-1
luci-proto-ppp - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci-mod-admin-full - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci-base - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
libjson-script - 2020-02-27-7da66430-1 - 2020-05-25-66195aee-1
luci-proto-ipv6 - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
libblobmsg-json - 2020-02-27-7da66430-1 - 2020-05-25-66195aee-1
jshn - 2020-02-27-7da66430-1 - 2020-05-25-66195aee-1
usign - 2019-08-06-5a52b379-1 - 2020-05-23-f1f65026-1
luci-lib-nixio - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci-lib-jsonc - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
luci - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
rpcd-mod-iwinfo - 2019-12-10-aaa08366-2 - 2020-05-26-67c8a3fd-1
luci-mod-network - git-20.136.49537-fb2f363-1 - git-20.229.71287-57456a7-1
Групповое обновление (по шаблону, как в apt или dnf) не предусмотрено?

Код: Выделить всё

root@OpenWrt:/etc/init.d$ opkg upgrade 'luci*'
Unknown package 'luci*'.
Только поштучно и по полным именам пакетов? Как-то так:

Код: Выделить всё

root@OpenWrt:/$ opkg upgrade busybox rpcd
Upgrading busybox on root from 1.30.1-5 to 1.30.1-6...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/busybox_1.30.1-6_i386_pentium4.ipk
Upgrading rpcd on root from 2019-12-10-aaa08366-2 to 2020-05-26-67c8a3fd-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/rpcd_2020-05-26-67c8a3fd-1_i386_pentium4
Configuring rpcd.
Configuring busybox.

Код: Выделить всё

root@OpenWrt:/$ opkg upgrade luci
Upgrading luci on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci_git-20.229.71287-57456a7-1_all.ipk
Configuring luci.

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 19:15

Olej писал(а):
19 авг 2020, 17:22
Групповое обновление (по шаблону, как в apt или dnf) не предусмотрено?
Действительно не предусмотрено.
Вот предложения с форума:
Можно использовать следующую команду

Код: Выделить всё

opkg upgrade $(opkg list-upgradable | awk '{print $1}')
И страница документации относительно пакетного менеджера OpenWRT (перевод мой):
Массовое обновление всех «обновляемых» пакетов не является хорошей идеей, так как opkg только указывает, что есть более новая версия пакета, но не выполняет дальнейшую оценку. Превышение свободного места во флэш-памяти или невозможность загрузить все необходимые обновления могут привести к поломке маршрутизатора. Однако, если вы хотите попробовать это, для этого есть однострочник:

Код: Выделить всё

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade
- обновляет все установленные пакеты, которые в настоящее время можно обновить.

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 20:17

Olej писал(а):
19 авг 2020, 19:15

Код: Выделить всё

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade
И выглядит это так:

Код: Выделить всё

root@OpenWrt:~# opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade
Upgrading luci-app-opkg on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-app-opkg_git-20.229.71287-57456a7-1_all.ipk
Upgrading luci-lib-ip on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-lib-ip_git-20.229.71287-57456a7-1_i386_pentium4.ipk
Upgrading luci-mod-system on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-mod-system_git-20.229.71287-57456a7-1_all.ipk
Upgrading luci-theme-bootstrap on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-theme-bootstrap_git-20.229.71287-57456a7-1_all.ipk
Upgrading libuclient20160123 on root from 2019-05-30-3b3e368d-1 to 2020-06-17-51e16ebf-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libuclient20160123_2020-06-17-51e16ebf-1_i386_pentium4.ipk
Upgrading luci-mod-status on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-mod-status_git-20.229.71287-57456a7-1_i386_pentium4.ipk
Upgrading firewall on root from 2019-11-22-8174814a-1 to 2019-11-22-8174814a-2...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/firewall_2019-11-22-8174814a-2_i386_pentium4.ipk
Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[0] (lan) cannot resolve device of network 'lan'
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan6'
Warning: Section @zone[0] (lan) has no device, network, subnet or extra options
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
 * Flushing conntrack table ...
Upgrading luci-app-firewall on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-app-firewall_git-20.229.71287-57456a7-1_all.ipk
Upgrading uclient-fetch on root from 2019-05-30-3b3e368d-1 to 2020-06-17-51e16ebf-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/uclient-fetch_2020-06-17-51e16ebf-1_i386_pentium4.ipk
Upgrading libubox20191228 on root from 2020-02-27-7da66430-1 to 2020-05-25-66195aee-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libubox20191228_2020-05-25-66195aee-1_i386_pentium4.ipk
Upgrading rpcd-mod-file on root from 2019-12-10-aaa08366-2 to 2020-05-26-67c8a3fd-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/rpcd-mod-file_2020-05-26-67c8a3fd-1_i386_pentium4.ipk
Upgrading luci-proto-ppp on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-proto-ppp_git-20.229.71287-57456a7-1_all.ipk
Upgrading luci-mod-admin-full on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-mod-admin-full_git-20.229.71287-57456a7-1_all.ipk
Upgrading luci-base on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-base_git-20.229.71287-57456a7-1_i386_pentium4.ipk
Upgrading libjson-script on root from 2020-02-27-7da66430-1 to 2020-05-25-66195aee-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libjson-script_2020-05-25-66195aee-1_i386_pentium4.ipk
Upgrading luci-proto-ipv6 on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-proto-ipv6_git-20.229.71287-57456a7-1_all.ipk
Upgrading libblobmsg-json on root from 2020-02-27-7da66430-1 to 2020-05-25-66195aee-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libblobmsg-json_2020-05-25-66195aee-1_i386_pentium4.ipk
Upgrading jshn on root from 2020-02-27-7da66430-1 to 2020-05-25-66195aee-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/jshn_2020-05-25-66195aee-1_i386_pentium4.ipk
Upgrading usign on root from 2019-08-06-5a52b379-1 to 2020-05-23-f1f65026-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/usign_2020-05-23-f1f65026-1_i386_pentium4.ipk
Upgrading luci-lib-nixio on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-lib-nixio_git-20.229.71287-57456a7-1_i386_pentium4.ipk
Upgrading luci-lib-jsonc on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-lib-jsonc_git-20.229.71287-57456a7-1_i386_pentium4.ipk
Upgrading rpcd-mod-iwinfo on root from 2019-12-10-aaa08366-2 to 2020-05-26-67c8a3fd-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/rpcd-mod-iwinfo_2020-05-26-67c8a3fd-1_i386_pentium4.ipk
Upgrading luci-mod-network on root from git-20.136.49537-fb2f363-1 to git-20.229.71287-57456a7-1...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/luci-mod-network_git-20.229.71287-57456a7-1_all.ipk
Configuring libubox20191228.
Configuring libuclient20160123.
Configuring uclient-fetch.
Configuring luci-app-opkg.
Configuring libblobmsg-json.
Configuring luci-lib-ip.
Configuring luci-lib-nixio.
Configuring luci-lib-jsonc.
Configuring rpcd-mod-file.
Configuring luci-base.
Configuring luci-mod-system.
Configuring luci-theme-bootstrap.
Configuring jshn.
Configuring libjson-script.
Configuring usign.
Configuring luci-mod-status.
Configuring firewall.
Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[0] (lan) cannot resolve device of network 'lan'
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan6'
 * Populating IPv4 filter table
   * Rule 'Allow-DHCP-Renew'
   * Rule 'Allow-Ping'
   * Rule 'Allow-IGMP'
   * Rule 'Allow-IPSec-ESP'
   * Rule 'Allow-ISAKMP'
   * Forward 'lan' -> 'wan'
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv4 nat table
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv4 mangle table
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv6 filter table
   * Rule 'Allow-DHCPv6'
   * Rule 'Allow-MLD'
   * Rule 'Allow-ICMPv6-Input'
   * Rule 'Allow-ICMPv6-Forward'
   * Rule 'Allow-IPSec-ESP'
   * Rule 'Allow-ISAKMP'
   * Forward 'lan' -> 'wan'
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv6 mangle table
   * Zone 'lan'
   * Zone 'wan'
 * Flushing conntrack table ...
 * Set tcp_ecn to off
 * Set tcp_syncookies to on
 * Set tcp_window_scaling to on
 * Running script '/etc/firewall.user'
Configuring luci-app-firewall.
Configuring luci-proto-ppp.
Configuring rpcd-mod-iwinfo.
Configuring luci-mod-network.
Configuring luci-mod-admin-full.
Configuring luci-proto-ipv6.
Collected errors:
 * resolve_conffiles: Existing conffile /etc/config/luci is different from the conffile in the new package. The new conffile will be placed at /etc/config/luci-opkg.
Всё, обновлять больше нечего:

Код: Выделить всё

root@OpenWrt:~# opkg list-upgradable 
root@OpenWrt:~#

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 20:40

Olej писал(а):
18 авг 2020, 20:27

Код: Выделить всё

root@OpenWrt:~# service dhcp reload
service "dhcp" not found, the following services are available:
boot          done          gpio_switch   network       sysctl        system        umount
cron          dropbear      led           odhcpd        sysfixtime    ucitrack      urandom_seed
dnsmasq       firewall      log           rpcd          sysntpd       uhttpd        urngd
Так мы, по ошибке, получаем список доступных сервисов...
Или вот они же - все установленные на сейчас в системе сервисы:

Код: Выделить всё

root@OpenWrt:~# ls /etc/init.d/
boot          done          gpio_switch   network       sysctl        system        umount
cron          dropbear      led           odhcpd        sysfixtime    ucitrack      urandom_seed
dnsmasq       firewall      log           rpcd          sysntpd       uhttpd        urngd
Это особенно важно для DHCP раздачи WiFi клиентам...

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 20 авг 2020, 17:35

Ещё одна загадка природы (для меня o.O ) команда service...
Для перезапуска любого сервиса (при его переконфигурации, например) делаем (в консоли или сеансе SSH) так:

Код: Выделить всё

root@OpenWrt:~# service network reload

Код: Выделить всё

root@OpenWrt:~# service network restart
Но!

Код: Выделить всё

root@OpenWrt:~# which service
root@OpenWrt:~#
Нет такого файла программы (или ссылки).
Вопрос №1: Что это за такая загадочная команда? Это какая-то внутренняя команда интерпретатора busybox/ash?

Запускаю оболочку mc:

Код: Выделить всё

root@OpenWrt:~# mc
root@OpenWrt:~$
Текст приглашения остался тем же: root@OpenWrt:~ (?), но значок приглашения сменился с # на $ ... т.е. это уже не root? И в итоге:

Код: Выделить всё

root@OpenWrt:~$ service
/bin/ash: service: not found
Вопрос №2: Кто и каким образом решает кому дозволено а кому нет выполнять команду service (и может ещё какие-то команды)?

Вопрос №3: Под каким именем продолжается сеанс всего лишь помле запуска оболочки mc? Есть ли команда для выяснения этого? - то что в любом "нормальном" Linux делают команды who, whoami ? Может какой-то пакет нужно дополнительно установить opkg?
P.S. Вообще то, программа mc не имеет какого-то особого пользователя-владельца, если даже предположить что при её запуске срабатывает SUID бит:

Код: Выделить всё

root@OpenWrt:~$ ls -l /usr/bin/mc
-rwxr-xr-x    1 root     root        786829 Aug 17 16:29 /usr/bin/mc

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 20 авг 2020, 17:36

Ещё вопрос по серверу DHCP ... у меня такое впечатление, что после установки всего, что относится к WiFi, клиентам WiFi не раздаётся IPv4 (но может это и ошибочное моё впечатление :sveta: ).
В системе установлено по умолчанию (после инсталляции, ничегов этой части не доустанавливалось):

Код: Выделить всё

root@OpenWrt:~# opkg list-installed | grep dhcp
odhcp6c - 2019-01-11-e199804b-16
odhcpd-ipv6only - 2020-05-03-49e4949c-3
Вот эти 6-ки в именах пакетов меня и смущают:

Код: Выделить всё

root@OpenWrt:~# opkg info odhcpd-ipv6only
Package: odhcpd-ipv6only
Version: 2020-05-03-49e4949c-3
Depends: libc, libubox20191228, libuci20130104, libubus20191227, libnl-tiny
Status: install user installed
Section: net
Architecture: i386_pentium4
Size: 33801
Filename: odhcpd-ipv6only_2020-05-03-49e4949c-3_i386_pentium4.ipk
Description: odhcpd is a daemon for serving and relaying IP management protocols to
 configure clients and downstream routers. It tries to follow the RFC 6204
 requirements for IPv6 home routers.
 
 This is a variant providing server services for RA, stateless and stateful
 DHCPv6,  prefix delegation and can be used to relay RA, DHCPv6 and NDP between
 routed (non-bridged) interfaces in case no delegated prefixes are available.
Installed-Time: 1589653940

root@OpenWrt:~# opkg info odhcp6c
Package: odhcp6c
Version: 2019-01-11-e199804b-16
Depends: libc, libubox20191228
Status: install user installed
Section: net
Architecture: i386_pentium4
Size: 26066
Filename: odhcp6c_2019-01-11-e199804b-16_i386_pentium4.ipk
Description: Embedded DHCPv6-client for OpenWrt
Installed-Time: 1589653940
Но в репозитории есть для установки:

Код: Выделить всё

root@OpenWrt:~# opkg list | grep ^odhcp
odhcp6c - 2019-01-11-e199804b-16 - Embedded DHCPv6-client for OpenWrt
odhcpd - 2020-05-03-49e4949c-3 - odhcpd is a daemon for serving and relaying IP management protocols to configure clients and downstream routers. It tries to follow the RFC 6204 requirements for IPv6 home routers.  This is a variant providing server services for DHCPv4, RA, stateless and stateful DHCPv6,  prefix delegation and can be used to relay RA, DHCPv6 and NDP between routed (non-bridged) interfaces in case no delegated prefixes are available.
odhcpd-ipv6only - 2020-05-03-49e4949c-3 - odhcpd is a daemon for serving and relaying IP management protocols to configure clients and downstream routers. It tries to follow the RFC 6204 requirements for IPv6 home routers.  This is a variant providing server services for RA, stateless and stateful DHCPv6,  prefix delegation and can be used to relay RA, DHCPv6 and NDP between routed (non-bridged) interfaces in case no delegated prefixes are available.

Код: Выделить всё

root@OpenWrt:~# opkg list | grep ^dhcp
...
dhcpcd - 7.2.2-1 - DHCPv4, IPv6RS and DHCPv6 client with IPv4LL support dhcpcd is a one stop network management daemon which includes * RFC compliant DHCPv4 and DHCPv6 clients * DHCPv6 Prefix Delegation support * IPv4LL (aka ZeroConf) support * ARP address conflict resolution * Link carrier detection * Wireless SSID profiles * ARP ping profiles
Если мне нафиг не надо всё что относится к IPv6, а интересует только IPv4 - нужно ли мне переустанавливать вместо odhcpd-ipv6only + odhcp6c набор odhcpd + dhcpcd ?

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 20 авг 2020, 18:25

Интересный эксперимент с алиасными IP для интерфейса... См. здесь: Aliases (а про сами интерфейсы в CLI сеансе - здесь: Network basics /etc/config/network)

Прописываю /etc/config/network:

Код: Выделить всё

root@OpenWrt:~$ cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd70:9a37:28cf::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipv6 '0'
	option ipaddr '192.168.1.5'
	option netmask '255.255.255.0'
	option gateway '192.168.1.3'
	option dns '8.8.8.8'

config interface lan2
	option 'ifname' 'br-lan'        # or use '@lan'
	option 'proto' 'static'
#       option 'ipaddr' '10.0.0.1'
#       option 'netmask' '255.255.255.0'
	option proto 'dhcp'
Затем:

Код: Выделить всё

root@OpenWrt:~# service network restart
И в итоге:

Код: Выделить всё

root@OpenWrt:~# ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 08:00:27:54:21:a3 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 08:00:27:54:21:a3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet 192.168.1.102/24 brd 192.168.1.255 scope global secondary br-lan
       valid_lft forever preferred_lft forever
Теперь я могу по одному физическому интерфейсу eth0 обращаться по 2-м разным IP, в том чисе и из разных подсетей!

Код: Выделить всё

root@OpenWrt:~# ubus list network.interface.*
network.interface.lan
network.interface.lan2
network.interface.loopback
Со стороннего хоста LAN:

Код: Выделить всё

olej@nvidia:~$ ping 192.168.1.102
PING 192.168.1.102 (192.168.1.102) 56(84) bytes of data.
64 bytes from 192.168.1.102: icmp_seq=1 ttl=64 time=0.684 ms
64 bytes from 192.168.1.102: icmp_seq=2 ttl=64 time=0.499 ms
64 bytes from 192.168.1.102: icmp_seq=3 ttl=64 time=0.488 ms
^C
--- 192.168.1.102 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2040ms
rtt min/avg/max/mdev = 0.488/0.557/0.684/0.089 ms

Ответить

Вернуться в «Одноплатные компьютеры»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость