OpenWRT

встраиваемые модели

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 29 июл 2020, 14:33

Olej писал(а):
29 июл 2020, 14:20
Некоторые полезные специфические команды OpenWRT ...
В OpenWRT изначально нечем посмотреть обнаруженные устройства на PCI шине ... это естественно, поскольку на большинстве платформ роутеров - MIPS, и там это не актуально.
Для этого нужно установить:

Код: Выделить всё

root@OpenWrt:~# opkg install pciutils
Installing pciutils (3.6.2-3) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/pciutils_3.6.2-3_i386_pentium4.ipk
Installing libkmod (20-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/libkmod_20-2_i386_pentium4.ipk
Configuring libkmod.
Configuring pciutils.
Тогда имеет то что хотели:

Код: Выделить всё

root@OpenWrt:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
09:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM5761e Gigabit Ethernet PCIe (rev 10)
0b:00.0 Network controller: Qualcomm Atheros AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) (rev 01)
0c:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 09 авг 2020, 13:54

В обсуждениях с коллегами возник вопрос: какие вообще чипы производителей поддерживает на сегодня OpenWRT ... в частности чипы ADSL 2+ ?
Все типы драйверов (модули ядра) - их очень много:

Код: Выделить всё

root@OpenWrt:~# opkg list kmod-* | wc -l
826
... на самом деле чуть меньше, потому что вывод для некоторых немногих чипов - многострочный с подробными разъяснениями ... типа такого:

Код: Выделить всё

kmod-usb-serial-simple - 4.14.180-1 - Kernel support for "very simple devices".
 Specifically, it supports:
 - Suunto ANT+ USB device.
 - Medtronic CareLink USB device (3.18)
 - Fundamental Software dongle.
 - Google USB serial devices (3.19)
 - HP4x calculators
 - a number of Motorola phones
 - Novatel Wireless GPS receivers (3.18)
 - Siemens USB/MPI adapter.
 - ViVOtech ViVOpay USB device.
 - Infineon Modem Flashloader USB interface
 - ZIO Motherboard USB serial interface
:lol:

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 09 авг 2020, 14:02

Olej писал(а):
09 авг 2020, 13:54
Все типы драйверов (модули ядра) - их очень много:
Полный перечень модулей ядра в последней версии - смотрим на их сайте в документации - Packages in kernel-modules category
kmod-3c59x
kmod-6lowpan
kmod-8139cp
kmod-8139too
kmod-9pnet
kmod-ac97
kmod-acx-mac80211
kmod-adm8211
kmod-airo
kmod-aoe
kmod-arptables
kmod-asn1-decoder
kmod-at86rf230
...
И поиск своего интересующего чипа нужно начинать именно отсюда...

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 09 авг 2020, 14:08

Olej писал(а):
09 авг 2020, 14:02
И поиск своего интересующего чипа нужно начинать именно отсюда...
Типа такого:
kmod-ltq-adsl-ar9
kmod-ltq-adsl-ar9-fw-a
kmod-ltq-adsl-ar9-fw-b
kmod-ltq-adsl-ar9-mei
kmod-ltq-adsl-ase
kmod-ltq-adsl-ase-fw-a
kmod-ltq-adsl-ase-fw-b
kmod-ltq-adsl-ase-mei
kmod-ltq-adsl-danube
kmod-ltq-adsl-danube-fw-a
kmod-ltq-adsl-danube-fw-b
kmod-ltq-adsl-danube-mei
Очень здорово, что идя по ссылке любого модуля даются все зависимые модули требуемые для работы:
package: kmod-ltq-adsl-ase
Name:kmod-ltq-adsl-ase
Version:see kernel for details
Description:adsl driver for ase\\ \\Installed size:54kB
Dependencies:kernel, kmod-ltq-adsl-ase-mei
Categories:kernel-modules
Repositories:base
OpenWrt release:OpenWrt-19.07.0
File size:55kB
Maintainer:John Crispin

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 18 авг 2020, 20:21

Olej писал(а):
23 июл 2020, 15:02
- но не имеет роутинга внаружу (не установлен дефаулт-шлюз, у меня в LAN это 192.168.1.3)
Опять был повод вернуться к конфигурированию сети...
Было:

Код: Выделить всё

root@OpenWrt:~# cat /etc/config/network
...
config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
При этом выхода в наружу, естественно, нет.
Добавляю:

Код: Выделить всё

root@OpenWrt:~# cat /etc/config/network
...
config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipv6 '0'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option gateway '192.168.1.3'
	option dns '8.8.8.8'
	option ip6assign '60'
Обязательно!

Код: Выделить всё

root@OpenWrt:~# service network reload
После чего:

Код: Выделить всё

root@OpenWrt:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.3     0.0.0.0         UG    0      0        0 br-lan
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Код: Выделить всё

root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=119 time=23.836 ms
64 bytes from 8.8.8.8: seq=1 ttl=119 time=22.184 ms
64 bytes from 8.8.8.8: seq=2 ttl=119 time=23.514 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 22.184/23.178/23.836 ms

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 18 авг 2020, 20:27

Olej писал(а):
18 авг 2020, 20:21
Обязательно!

Код: Выделить всё

root@OpenWrt:~# service network reload
Перезапуск сервисов OpenWRT делается именно так, например:

Код: Выделить всё

root@OpenWrt:~# service dhcp reload
service "dhcp" not found, the following services are available:
boot          done          gpio_switch   network       sysctl        system        umount
cron          dropbear      led           odhcpd        sysfixtime    ucitrack      urandom_seed
dnsmasq       firewall      log           rpcd          sysntpd       uhttpd        urngd
Так мы, по ошибке, получаем список доступных сервисов... и:

Код: Выделить всё

root@OpenWrt:~# service odhcpd reload

Код: Выделить всё

root@OpenWrt:~# service odhcpd status
Syntax: /etc/init.d/odhcpd [command]

Available commands:
	start	Start the service
	stop	Stop the service
	restart	Restart the service
	reload	Reload configuration files (or restart if service does not implement reload)
	enable	Enable service autostart
	disable	Disable service autostart

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 18 авг 2020, 20:30

Olej писал(а):
18 авг 2020, 20:21
Добавляю:
Параметрами /etc/config/network руководствуюсь здесь - UCI networking options cheatsheet
This is a cheatsheet for quick lookup of networking UCI options, useful for experienced users.

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 16:54

Olej писал(а):
18 авг 2020, 20:30
Параметрами /etc/config/network руководствуюсь здесь - UCI networking options cheatsheet
А проконтролировать текущее состояние так:

Код: Выделить всё

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd70:9a37:28cf::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0'
network.lan.proto='static'
network.lan.ipv6='0'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.gateway='192.168.1.3'
network.lan.dns='8.8.8.8'
network.lan.ip6assign='60'

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 17:02

Olej писал(а):
18 авг 2020, 20:21
Обязательно!

Код: Выделить всё

root@OpenWrt:~# service network reload
Удивительное дело! :lol: Но при загрузке той же виртуальной машины без переконфигурации ( :!: ):

Код: Выделить всё

root@OpenWrt:~# which service
root@OpenWrt:~# 
И ни в какую! - нет такой программы и всё тут :-o
Читаем Network basics /etc/config/network
After any network configuration change (through uci or otherwise) you need to reload the network configuration in the netifd daemon by writing:

Код: Выделить всё

service network reload
If your install does not supply the service command, a reload can be accomplished with:

Код: Выделить всё

/etc/init.d/network reload
Thanks to netifd (Network Interface Daemon), the changed interfaces will be restarted automatically to apply the changes live. Rebooting the router is not necessary, but is also another way that will force a configuration reload.
Что может означать "If your install does not supply the service command" - для меня загадка?! Вчера, значит, поддерживала, а сегодня нет? :twisted:
Тем не менее, это не мешает развитию:

Код: Выделить всё

root@OpenWrt:~# /etc/init.d/network 
Syntax: /etc/init.d/network [command]

Available commands:
	start	Start the service
	stop	Stop the service
	restart	Restart the service
	reload	Reload configuration files (or restart if service does not implement reload)
	enable	Enable service autostart
	disable	Disable service autostart

Всё путём, можно и так...

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 19 авг 2020, 17:07

Очень квалифицированный форум по тонким "мелочам" по OpenWRT + там можно быстро получить ответ на свой вопрос:
Изображение
255 (на момент написания) страниц форума!

Ответить

Вернуться в «Одноплатные компьютеры»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость