OpenWRT

встраиваемые модели

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 15:10

Olej писал(а):
23 июл 2020, 15:02
Сразу же по загрузке доступен WEB-интерфейс по 192.168.1.1:
Имеем полнейшую диагностику + меню для самого разнообразного WEB-конфигурирования ... так что и стартовая консоль нам вряд ли нужна:
Снимок экрана от 2020-07-23 15-07-09.png
Но ряд опций (настроек) недоступны без пароля root ... поэтому не буду испытывать судьбу, и установлю пароль в консоли запуска:
Снимок экрана от 2020-07-23 15-11-48.png
Снимок экрана от 2020-07-23 15-11-48.png (24.69 КБ) 250 просмотров
Пароль ему не нравится :lol: (предупреждает) ... но он его съел!

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 15:39

Olej писал(а):
23 июл 2020, 15:10
меню для самого разнообразного WEB-конфигурирования ...
Теперь я могу переконфигурировать сетевой интерфейс (и добавить ещё сколько нужно WAN & LAN ;-) ) под свои желания:
Снимок экрана от 2020-07-23 15-28-25.png
Но ...
... я никак не могу изменить IP/gate этого интерфейса из его упоротых 192.168.1.1! Ни Restart самого интерфейса, ни reboot машины... :evil: :-o

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 17:00

Olej писал(а):
23 июл 2020, 15:39
... я никак не могу изменить IP/gate этого интерфейса из его упоротых 192.168.1.1! Ни Restart самого интерфейса, ни reboot машины...
Могу это сделать только из консоли OpenWRT, запустив редактор для файла конфигурации /etc/config/network:

Код: Выделить всё

# vi /etc/config/network
...
После команды reboot имеем:
Снимок экрана от 2020-07-23 16-46-46.png
Снимок экрана от 2020-07-23 16-46-46.png (23.2 КБ) 249 просмотров
ping идёт с любого хоста LAN:

Код: Выделить всё

olej@nvidia:~/2020_WORK$ ping 192.168.1.15
PING 192.168.1.15 (192.168.1.15) 56(84) bytes of data.
64 bytes from 192.168.1.15: icmp_seq=1 ttl=64 time=0.487 ms
64 bytes from 192.168.1.15: icmp_seq=2 ttl=64 time=0.486 ms
64 bytes from 192.168.1.15: icmp_seq=3 ttl=64 time=0.617 ms
^C
--- 192.168.1.15 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2033ms
rtt min/avg/max/mdev = 0.486/0.530/0.617/0.061 ms
Снимок экрана от 2020-07-23 16-53-06.png
Снимок экрана от 2020-07-23 16-53-06.png (29.19 КБ) 249 просмотров
И OpenWRT получает выход в Интернет:
Снимок экрана от 2020-07-23 16-53-48.png
Снимок экрана от 2020-07-23 16-53-48.png (30.17 КБ) 249 просмотров
И, естественно, WEB-интерфейс OpenWRT теперь открывается по URL в адресной строке браузера: http://192.168.1.15

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 17:09

Olej писал(а):
23 июл 2020, 17:00
Могу это сделать только из консоли OpenWRT
Дальше консольные команды OpenWRT лучше и проще выполнять в сессии SSH, открытой в терминале стационарного десктопа:

Код: Выделить всё

olej@nvidia:~$ ssh -lroot 192.168.1.15
The authenticity of host '192.168.1.15 (192.168.1.15)' can't be established.
RSA key fingerprint is SHA256:CT58N0eTt6sJgq1AHB4UntJqQIH1bG7GcgZRVqMa6jU.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '192.168.1.15' (RSA) to the list of known hosts.
root@192.168.1.15's password: 


BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 17:33

Olej писал(а):
23 июл 2020, 17:09
Дальше консольные команды OpenWRT
Начиная с того, что перестроить eth0 со статической настройки на DHCP, чтобы не возиться с настройками DNS OpenWRT:

Код: Выделить всё

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3a:c859:1cf9::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'
После перезагрузки и возобновления сессии SSH - обновление пакетной системы:

Код: Выделить всё

root@OpenWrt:~# time opkg update
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/x86/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading http://downloads.openwrt.org/releases/19.07.3/targets/x86/generic/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/luci/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/routing/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Command exited with non-zero status 1
real	0m 46.31s
user	0m 0.20s
sys	0m 0.02s

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 17:41

Olej писал(а):
23 июл 2020, 17:33
обновление пакетной системы
После чего можете доустанавливать из Интернет всё что пожелаете:

Код: Выделить всё

root@OpenWrt:~# opkg install mc
Installing mc (4.8.23-3) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/mc_4.8.23-3_i386_pentium4.ipk
Installing zlib (1.2.11-3) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/zlib_1.2.11-3_i386_pentium4.ipk
Installing libffi (3.2.1-3) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/libffi_3.2.1-3_i386_pentium4.ipk
Installing libattr (2.4.48-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/libattr_2.4.48-1_i386_pentium4.ipk
Installing glib2 (2.58.3-5) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/glib2_2.58.3-5_i386_pentium4.ipk
Installing terminfo (6.1-5) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/terminfo_6.1-5_i386_pentium4.ipk
Installing libncurses6 (6.1-5) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libncurses6_6.1-5_i386_pentium4.ipk
Installing libmount1 (2.34-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libmount1_2.34-1_i386_pentium4.ipk
Installing libmbedtls12 (2.16.6-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/base/libmbedtls12_2.16.6-1_i386_pentium4.ipk
Installing libssh2-1 (1.9.0-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.3/packages/i386_pentium4/packages/libssh2-1_1.9.0-2_i386_pentium4.ipk
Configuring terminfo.
Configuring zlib.
Configuring libffi.
Configuring libattr.
Configuring glib2.
Configuring libncurses6.
Configuring libmount1.
Configuring libmbedtls12.
Configuring libssh2-1.
Configuring mc.

Код: Выделить всё

root@OpenWrt:~# which mc
/usr/bin/mc

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 23 июл 2020, 17:45

Olej писал(а):
23 июл 2020, 17:41

Код: Выделить всё

root@OpenWrt:~# which mc
/usr/bin/mc
Запуск в консоли (виртуальной) OpenWRT:
Снимок экрана от 2020-07-23 17-40-43.png
Снимок экрана от 2020-07-23 17-40-43.png (29.73 КБ) 247 просмотров
Хотя то же можно сделать (и удобнее) в терминале SSH сессии:
Снимок экрана от 2020-07-23 17-41-18.png
Снимок экрана от 2020-07-23 17-41-18.png (85.59 КБ) 247 просмотров
И таких SSH сессий (отдельных терминалов, или вкладок терминала) с запущенными mc - можно создать сколь угодно много (для параллельного выполнения операций).

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 24 июл 2020, 20:31

Поскольку OpenWRT - это даже не дистрибутив Linux, а инфраструктура на базе Linux для встраивания в разнообразное железо, то тема перенесена в этот более уместный раздел форума: Одноплатные компьютеры

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 29 июл 2020, 14:20

Некоторые полезные специфические команды OpenWRT ... которые отличаются от привычного Linux (или имеют другие возможности)...

1. Посмотреть системный лог, особенно важно это дл фиксации всех WiFi подключений со стороны:

Код: Выделить всё

root@OpenWrt:~# logread
...
Wed Jul 29 13:31:13 2020 authpriv.info dropbear[18013]: Child connection from 192.168.1.11:35398
Wed Jul 29 13:31:15 2020 authpriv.notice dropbear[18013]: Password auth succeeded for 'root' from 192.168.1.11:35398
Wed Jul 29 13:40:05 2020 daemon.info hostapd: wlan0: STA 38:a4:ed:4a:ca:9f IEEE 802.11: authenticated
Wed Jul 29 13:40:05 2020 daemon.info hostapd: wlan0: STA 38:a4:ed:4a:ca:9f IEEE 802.11: associated (aid 1)
Wed Jul 29 13:40:05 2020 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 38:a4:ed:4a:ca:9f

Аватара пользователя
Olej
Писатель
Сообщения: 13885
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: OpenWRT

Непрочитанное сообщение Olej » 29 июл 2020, 14:26

Olej писал(а):
29 июл 2020, 14:20
Некоторые полезные специфические команды OpenWRT ...
2. Служба cron, запуск по расписанию...

Код: Выделить всё

root@OpenWrt:~# /etc/init.d/cron
Syntax: /etc/init.d/cron [command]

Available commands:
    start       Start the service
    stop        Stop the service
    restart     Restart the service
    reload      Reload configuration files (or restart if service does not implement reload)
    enable      Enable service autostart
    disable     Disable service autostart
А вот как правила запуска в cron выглядят в WEB-морде управления OpenWRT (так кнечно гораздо проще):
Снимок экрана от 2020-07-29 14-22-44.png
Детальное описание (там много специфики) на странице документации OpenWRT: Cron and crontab
Cron allows to run jobs (programs, scripts) at specified times.
OpenWrt comes with a cron system by default, provided by busybox.
...

Ответить

Вернуться в «Одноплатные компьютеры»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость