Viber

Браузеру, почта, IP-телефония и т.п.

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 21 сен 2018, 12:46

ypan49 писал(а):Свежая публикация от 14-го сентября 2018г. по этому вопросу "Решение проблемы установки Viber в Ubuntu 18.04 LTS Bionic Beaver" здесь http://compizomania.blogspot.com/2018/0 ... eaver.html
Мне бы надо и телефон симитировать на компьютере (нету), чтоб без телефона и в Вабере и чтоб не в виртуальной машине, а в текущей операционке.
Из вашей ссылки самое интересное :-( важное вот это:
Одним из самых популярных мессенджеров в мире считается Viber, но, к сожалению, нынешний его владелец Rakuten Viber прекратил его разработку и поддержку под Linux.

После отказа от дальнейшей разработки около года назад, последней версией Viber под Linux является версия 7.0.0.1035, которая пока ещё доступна для скачивания на сайте мессенджера.
Что более понятно по-русски можно пересказать так: теперь от Viber десктопа под Linux следует отказаться и забыть. :cry:
P.S. ... а может и просто "отказаться и забыть" от Viber в сравнении с Telegram и WhatApps? ;-)

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 28 янв 2019, 10:48

Olej писал(а):
После отказа от дальнейшей разработки около года назад, последней версией Viber под Linux является версия 7.0.0.1035, которая пока ещё доступна для скачивания на сайте мессенджера.
Что более понятно по-русски можно пересказать так: теперь от Viber десктопа под Linux следует отказаться и забыть. :cry:
P.S. ... а может и просто "отказаться и забыть" от Viber в сравнении с Telegram и WhatApps? ;-)
В новых инсталляциях некоторых дистрибутивов эту "остаточную" версию Viber под Linux уже и установить нельзя (версии библиотек и зависимости):

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux buster/sid
Release:	testing
Codename:	buster

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ sudo dpkg -i viber.deb 
[sudo] пароль для olej: 
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 373708 файлов и каталогов.)
Подготовка к распаковке viber.deb …
Распаковывается viber (7.0.0.1035) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.
 viber зависит от libcurl3, однако:
  Пакет libcurl3 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для mime-support (3.61) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ sudo apt install libcurl3-dev 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «libcurl3-dev» выбирается «libcurl4-openssl-dev»
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt --fix-broken install».
Следующие пакеты имеют неудовлетворённые зависимости:
 viber : Зависит: libssl1.0.0 но он не может быть установлен
         Зависит: libcurl3 но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 15 мар 2019, 20:58

Olej писал(а): В новых инсталляциях некоторых дистрибутивов эту "остаточную" версию Viber под Linux уже и установить нельзя (версии библиотек и зависимости):
Ещё новости :-( ... После некоторого обновления Mint 19:

Код: Выделить всё

olej@nvidia:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	LinuxMint
Description:	Linux Mint 19.1 Tessa
Release:	19.1
Codename:	tessa
Тот Viber, который ещё недавно работал (и который был установлен в какие-то баснословные времена ... когда Mint обновлялся 18.1 -> 18.2 -> 18.3 -> 19 ...) работать перестал:

Код: Выделить всё

olej@nvidia:~$ /opt/viber/Viber
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
QGLXContext: Failed to create dummy context
qml: type=""
failed to acquire GL context to resolve capabilities, using defaults..
qml: type=""
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile)) 
Аварийный останов
И попытка переустановки:

Код: Выделить всё

olej@nvidia:~$ apt search viber
i   viber                                                                - Free Text & Calls.                                                            

olej@nvidia:~$ sudo apt reinstall viber
W: Package viber had been marked to reinstall, but the file for the current installed version 7.0.0.1035 is not available
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
  viber 
Следующие пакеты будут УДАЛЕНЫ:
  linux-modules-extra-4.15.0-43-generic{u} 
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
E: Невозможно найти источник для загрузки «viber:amd64» версии «7.0.0.1035»
После распаковки освободится 171 MБ.
Хотите продолжить? [Y/n/?] y
E: Невозможно найти источник для загрузки «viber:amd64» версии «7.0.0.1035»
E: Внутренняя ошибка: не удалось создать список пакетов для скачивания
E: Perhaps the package lists are out of date, please try 'aptitude update' (or equivalent); otherwise some packages or versions are not available from the current repository sources
И так будет, естественно, со всеми существующими инсталляциями: библиотеки (OpenGL и др.) обновляются, а застывший Viber опирается на поддержку прежних версий... :-(

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 апр 2019, 11:22

Olej писал(а): Что более понятно по-русски можно пересказать так: теперь от Viber десктопа под Linux следует отказаться и забыть. :cry:
P.S. ... а может и просто "отказаться и забыть" от Viber в сравнении с Telegram и WhatApps? ;-)
Но народ русскоязычный активно и упорно использует именно Viber (в отличие от многих других стран мира, где Viber не нашёл особо применения, по сравнению с WhatApps, например).
Особенно это касается народа, профессионально никак не завязанного на IT ... и их переубеждать дело безнадёжное...

И народ в Интернет упорно ищет и пишет способы установки десктопа Viber, пусть и устаревшего as is, на Linux:
Как установить Viber на Linux
Alexey 09.10.2018
По дате судя, это всё проделывалось уже после прекращения поддержки Viber в Linux, и когда повылазили несовместимости.
Прямо хочется даже проверить... :lol:

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 апр 2019, 12:41

Код: Выделить всё

olej@ACER:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux buster/sid
Release:	testing
Codename:	buster
Olej писал(а):Прямо хочется даже проверить... :lol:
После обновления по этой инструкции:

Код: Выделить всё

olej@ACER:~/2019_WORK/own.WORK/Viber$ ls -l *.deb
-rw-r--r-- 1 olej olej 83906144 апр 13 11:07 viber.deb
-rw-r--r-- 1 olej olej 83903280 апр 13 12:11 viber_fixed.deb

olej@ACER:~/2019_WORK/own.WORK/Viber$ sudo dpkg -i viber_fixed.deb
[sudo] пароль для olej: 
(Чтение базы данных … на данный момент установлено 382425 файлов и каталогов.)
Подготовка к распаковке viber_fixed.deb …
Распаковывается viber (10.3.0.37) на замену (10.3.0.37) …
Настраивается пакет viber (10.3.0.37) …
Обрабатываются триггеры для mime-support (3.62) …
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Всё устанавливается, всё стартует, запрашивает связь с телефоном (как и раньше это было) ... И заканчивается это всё "Нет подключения" :-o - это на том хосте с которого я сейчас пишу в форум :shock: :
Вложения
v1.png

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 апр 2019, 13:31

Olej писал(а):И заканчивается это всё "Нет подключения" :-o - это на том хосте с которого я сейчас пишу в форум :shock: :
Вот ручной запуск, в терминале:

Код: Выделить всё

olej@ACER:~/2019_WORK/own.WORK/Viber$ /opt/viber/Viber
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
qt.network.ssl: QSslSocket: cannot resolve sk_new_null
qt.network.ssl: QSslSocket: cannot resolve sk_push
qt.network.ssl: QSslSocket: cannot resolve sk_free
qt.network.ssl: QSslSocket: cannot resolve sk_num
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
qt.network.ssl: QSslSocket: cannot resolve sk_value
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
qt.network.ssl: QSslSocket: cannot resolve SSLeay
qt.network.ssl: Incompatible version of OpenSSL
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_CTX_new
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_CTX_new
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_CTX_new
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
qt.network.ssl: QSslSocket: cannot call unresolved function ERR_get_error
[11327:11327:0413/125939.995016:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
Это уже задрочки Qt с SSL пошли ... - и версия ему не та, и функции ему не те... :-?

Код: Выделить всё

olej@ACER:~/2019_WORK/own.WORK/Viber$ openssl version
OpenSSL 1.1.1b  26 Feb 2019

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 июн 2019, 19:31

Возобновление разработки Viber под Linux. Установка в Ubuntu/Linux Mint
06 АПРЕЛЯ 2019

Произошло радостное событие и разум всё таки возобладал! Компания Rakuten Viber возобновила разработку версий месенджера Viber под Linux и выложила новую версию для загрузки.
Есть надежда, что впредь Rakuten Viber больше никогда не будет прекращать разработку данного мессенджера под Linux, учитывая растущее огромное количество пользователей Linux-систем.
В этой статье я хочу вам напомнить, как можно установить обновлённый месенджер Viber в Ubuntu/Mint.

Скачиваем свежую версию Viber с сайта мессенджера и устанавливаем её:
cd /tmp; wget https://download.cdn.viber.com/cdn/desk ... /viber.deb; sudo dpkg -i viber.deb

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ wget https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
--2019-06-13 19:29:39--  https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
Распознаётся download.cdn.viber.com (download.cdn.viber.com)… 78.154.185.32, 78.154.185.34
Подключение к download.cdn.viber.com (download.cdn.viber.com)|78.154.185.32|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 OK
Длина: 83906144 (80M) [binary/octet-stream]
Сохранение в: «viber.deb.1»

viber.deb.1                                  100%[=============================================================================================>]  80,02M  3,52MB/s    за 24s     

2019-06-13 19:30:03 (3,36 MB/s) - «viber.deb.1» сохранён [83906144/83906144]

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 июн 2019, 19:50

Их DEB пакет не ставится в новых Debian из-за конфликта в версиях библиотек:

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ sudo dpkg -i viber.deb 
[sudo] пароль для olej: 
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 382523 файла и каталога.)
Подготовка к распаковке viber.deb …
chown: невозможно получить доступ к '/home/olej/Documents/ViberDownloads': Нет такого файла или каталога
Распаковывается viber (10.3.0.37) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для mime-support (3.62) …
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ aptitude search libssl1
i   libssl1.1                                                                         - инструментарий Secure Sockets Layer — разделяемые библиотеки                               

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 13 июн 2019, 21:25

Olej писал(а):Их DEB пакет не ставится в новых Debian из-за конфликта в версиях библиотек:
А в восторженных обсуждениях цитируют переписку с командой разработчиков Viber (огбратите внимание на дату письма!):
Re: Audio Issues CASE #6564106
Lilia M. wrote:Apr 24, 2019 07:07 PM
To You
Добрый день, Сергей.

Благодарим Вас за ожидание.

К сожалению, нам пришлось прекратить разработку приложения для некоторых операционных систем, включая Linux OS.

Приложение все еще может работать корректно для большинства пользователей на данных платформах, но мы не можем этого гарантировать. В то же время мы передали предоставленную Вами информацию нашей команде и они учтут ее, если мы снова запланируем выпуск новой версии для Вашей ОС.

Приносим свои искренние извинения за Ваши неудобства и надеемся, что Вы все еще сможете наслаждаться приложением Viber на других платформах.

Kind regards,
Lilia M.
Viber Support Team
Quick question? Tweet to @ViberHelp

Аватара пользователя
Olej
Писатель
Сообщения: 12803
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 05 сен 2019, 18:11

Совершенно безумный проект Viber под Linux :-o :
- на свежих Linux (Debian 10) он не устанавливается по зависимостям...
- на очень старых Linux (Mint 17) даже обновляемых совсем до свежих (Mint 19.2) он продолжает работать

Вот сколько библиотек он тянет по зависимостям:

Код: Выделить всё

olej@nvidia:~/2019_WORK/HISTORY/09/05$ ldd /opt/viber/Viber
	linux-vdso.so.1 (0x00007ffc7e2be000)
	libXss.so.1 => /usr/lib/x86_64-linux-gnu/libXss.so.1 (0x00007f8bc1762000)
	libqrencode.so => /opt/viber/lib/libqrencode.so (0x00007f8bc1551000)
	libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f8bc12c5000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f8bc10b3000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f8bc0d7b000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f8bc0b5e000)
	libQt5Sql.so.5 => /opt/viber/lib/libQt5Sql.so.5 (0x00007f8bc1b09000)
	libQt5Concurrent.so.5 => /opt/viber/lib/libQt5Concurrent.so.5 (0x00007f8bc1b03000)
	libQt5Multimedia.so.5 => /opt/viber/lib/libQt5Multimedia.so.5 (0x00007f8bc19f4000)
	libQt5Location.so.5 => /opt/viber/lib/libQt5Location.so.5 (0x00007f8bc09c5000)
	libQt5WebSockets.so.5 => /opt/viber/lib/libQt5WebSockets.so.5 (0x00007f8bc19c9000)
	libQt5WebEngine.so.5 => /opt/viber/lib/libQt5WebEngine.so.5 (0x00007f8bc0963000)
	libQt5PrintSupport.so.5 => /opt/viber/lib/libQt5PrintSupport.so.5 (0x00007f8bc08f4000)
	libQt5DBus.so.5 => /opt/viber/lib/libQt5DBus.so.5 (0x00007f8bc0872000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f8bc066e000)
	libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f8bc041e000)
	libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007f8bc0117000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f8bbfef8000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f8bbfcf0000)
	libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f8bbfae8000)
	libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f8bbf8cd000)
	libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f8bbf6ca000)
	libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f8bbf4c7000)
	libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f8bbf2c1000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f8bbf0b7000)
	libicui18n.so.52 => /opt/viber/lib/libicui18n.so.52 (0x00007f8bbec5b000)
	libicuuc.so.52 => /opt/viber/lib/libicuuc.so.52 (0x00007f8bbe8c0000)
	libQt5WebEngineCore.so.5 => /opt/viber/lib/libQt5WebEngineCore.so.5 (0x00007f8bb7f17000)
	libQt5Quick.so.5 => /opt/viber/lib/libQt5Quick.so.5 (0x00007f8bb7ab6000)
	libQt5WebChannel.so.5 => /opt/viber/lib/libQt5WebChannel.so.5 (0x00007f8bc19a5000)
	libQt5Qml.so.5 => /opt/viber/lib/libQt5Qml.so.5 (0x00007f8bb76ba000)
	libQt5Network.so.5 => /opt/viber/lib/libQt5Network.so.5 (0x00007f8bb752d000)
	libQt5Positioning.so.5 => /opt/viber/lib/libQt5Positioning.so.5 (0x00007f8bb74d0000)
	libQt5Widgets.so.5 => /opt/viber/lib/libQt5Widgets.so.5 (0x00007f8bb6e79000)
	libQt5Gui.so.5 => /opt/viber/lib/libQt5Gui.so.5 (0x00007f8bb68f0000)
	libQt5Core.so.5 => /opt/viber/lib/libQt5Core.so.5 (0x00007f8bb62bb000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f8bb5f32000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f8bb5b94000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f8bb597c000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8bb558b000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f8bc1966000)
	libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f8bb535a000)
	libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f8bb50a4000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f8bb4e7c000)
	libpulse-mainloop-glib.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-mainloop-glib.so.0 (0x00007f8bb4c77000)
	libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f8bb4960000)
	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f8bb4713000)
	libpulsecommon-11.1.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so (0x00007f8bb4495000)
	libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f8bb428e000)
	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f8bb4079000)
	libicudata.so.52 => /opt/viber/lib/libicudata.so.52 (0x00007f8bb280b000)
	libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f8bb2607000)
	libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f8bb23b3000)
	libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f8bb21b1000)
	libnss3.so => /usr/lib/x86_64-linux-gnu/libnss3.so (0x00007f8bb1e6d000)
	libnssutil3.so => /usr/lib/x86_64-linux-gnu/libnssutil3.so (0x00007f8bb1c3e000)
	libsmime3.so => /usr/lib/x86_64-linux-gnu/libsmime3.so (0x00007f8bb1a12000)
	libplds4.so => /usr/lib/x86_64-linux-gnu/libplds4.so (0x00007f8bb180e000)
	libplc4.so => /usr/lib/x86_64-linux-gnu/libplc4.so (0x00007f8bb1609000)
	libnspr4.so => /usr/lib/x86_64-linux-gnu/libnspr4.so (0x00007f8bb13cc000)
	libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f8bb11ca000)
	libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f8bb0fc0000)
	libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f8bb0db0000)
	libXtst.so.6 => /usr/lib/x86_64-linux-gnu/libXtst.so.6 (0x00007f8bb0baa000)
	libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f8bb0965000)
	libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f8bb06b1000)
	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f8bb047f000)
	libpng12.so.0 => /opt/viber/lib/libpng12.so.0 (0x00007f8bb0256000)
	libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f8bb004b000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f8bafe30000)
	libEGL.so.1 => /usr/lib/x86_64-linux-gnu/libEGL.so.1 (0x00007f8bafc1c000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f8bafa18000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f8baf812000)
	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f8baf5a0000)
	libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f8baf31c000)
	libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f8baf112000)
	libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f8baee99000)
	libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f8baec93000)
	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f8baea8b000)
	libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f8bae859000)
	liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f8bae633000)
	liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007f8bae417000)
	libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f8bae0fc000)
	libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f8badee2000)
	libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f8badc6b000)
	libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f8bada62000)
	libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f8bad837000)
	libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f8bad58e000)
	libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f8bad379000)
И что удивительно? Что здесь нет библиотеки, которую он требует по зависимостям из новой инсталляции!

Код: Выделить всё

olej@nvidia:~/2019_WORK/HISTORY/09/05$ ldd /opt/viber/Viber | grep libssl1
olej@nvidia:~/2019_WORK/HISTORY/09/05$
Вложения
Снимок экрана от 2019-09-05 18-11-06.png

Ответить

Вернуться в «Интернет и коммуниации»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость