Viber

Браузеру, почта, IP-телефония и т.п.

Модераторы: Olej, vikos

Аватара пользователя
Olej
Писатель
Сообщения: 12810
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 05 сен 2019, 18:24

Olej писал(а):Совершенно безумный проект Viber под Linux :-o :
Но характерно, что:
- обновлённая версия на Android - 11.4.0.22
- версии скачиваемые с сайта для Win/Mac - 10.11
- а работающая версия в Mint 19.2 - так и есть 7.0.0
Вложения
Снимок экрана от 2019-09-05 18-21-37.png
Снимок экрана от 2019-09-05 18-21-37.png (11.45 КБ) 94 просмотра

Аватара пользователя
Olej
Писатель
Сообщения: 12810
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 03 дек 2019, 16:13

Olej писал(а):
05 сен 2019, 18:11
Совершенно безумный проект Viber под Linux :-o :
- на свежих Linux (Debian 10) он не устанавливается по зависимостям...
- на очень старых Linux (Mint 17) даже обновляемых совсем до свежих (Mint 19.2) он продолжает работать
Что характерно ... что в весьма свежей Fedora 30 - происходит следующее:
1. Качаем (как и для всех дистрибутивов): Viber for Desktop:

Код: Выделить всё

[olej@xenix Messengers]$ ls -l viber.rpm 
-rw-rw-r-- 1 olej olej 132912697 дек  3 14:49 viber.rpm
2. Ранее (18.07.2018) уже был установлен Viber с их сайта (т.е. он успешно ставится):

Код: Выделить всё

[olej@xenix Messengers]$ ls -l viber*
-rw-rw-r-- 1 olej olej 141734983 июл 18 15:19 viber.rpm

[olej@xenix Messengers]$ sudo dnf install viber.rpm
[sudo] пароль для olej:
Последняя проверка окончания срока действия метаданных: 2:04:27 назад, Ср 18 июл 2018 13:15:36.
Зависимости разрешены.
========================================================================================================================
 Пакет                     Архитектура             Версия                           Репозиторий                   Размер
========================================================================================================================
Установка:
 viber                     x86_64                  7.0.0.1035-2                     @commandline                  135 M
Установка зависимостей:
 libnsl                    x86_64                  2.27-30.fc28                     updates                        77 k
 libpng12                  x86_64                  1.2.57-5.fc28                    fedora                        159 k

Результат транзакции
========================================================================================================================
Установка  3 Пакеты

Общий размер: 135 M
Объем загрузки: 236 k
Объем изменений: 409 M
Продолжить? [д/Н]: y
Загрузка пакетов:
(1/2): libpng12-1.2.57-5.fc28.x86_64.rpm                                                877 kB/s | 159 kB     00:00
(2/2): libnsl-2.27-30.fc28.x86_64.rpm                                                   314 kB/s |  77 kB     00:00
------------------------------------------------------------------------------------------------------------------------
Общий размер                                                                            142 kB/s | 236 kB     00:01
Проверка транзакции
Проверка транзакции успешно завершена.
Идет проверка транзакции
Тест транзакции проведен успешно
Выполнение транзакции
  Подготовка       :                                                                                                1/1
  Установка        : libnsl-2.27-30.fc28.x86_64                                                                     1/3
  Установка        : libpng12-1.2.57-5.fc28.x86_64                                                                  2/3
  Запуск скриптлета: libpng12-1.2.57-5.fc28.x86_64                                                                  2/3
  Установка        : viber-7.0.0.1035-2.x86_64                                                                      3/3
  Запуск скриптлета: viber-7.0.0.1035-2.x86_64                                                                      3/3
  Проверка         : viber-7.0.0.1035-2.x86_64                                                                      1/3
  Проверка         : libpng12-1.2.57-5.fc28.x86_64                                                                  2/3
  Проверка         : libnsl-2.27-30.fc28.x86_64                                                                     3/3

Установлено:
  viber.x86_64 7.0.0.1035-2             libnsl.x86_64 2.27-30.fc28             libpng12.x86_64 1.2.57-5.fc28

Выполнено!
Но тогда это была версия 7.0.0:
v1.png
v1.png (11.49 КБ) 31 просмотр
3. Теперь - переустановка:

Код: Выделить всё

[olej@xenix Messengers]$ sudo dnf install viber.rpm 
[sudo] пароль для olej: 
Последняя проверка окончания срока действия метаданных: 1:26:00 назад, Вт 03 дек 2019 13:34:43.
Зависимости разрешены.
=======================================================================================================================================================================
 Пакет                               Архитектура                          Версия                                      Репозиторий                                Размер
=======================================================================================================================================================================
Обновление:
 viber                               x86_64                               12.0.0.7-2                                  @commandline                               127 M

Результат транзакции
=======================================================================================================================================================================
Обновление  1 Пакет

Общий размер: 127 M
Продолжить? [д/Н]: y
Загрузка пакетов:
Проверка транзакции
Проверка транзакции успешно завершена.
Идет проверка транзакции
Тест транзакции проведен успешно
Выполнение транзакции
  Подготовка       :                                                                                                                                               1/1 
  Обновление       : viber-12.0.0.7-2.x86_64                                                                                                                       1/2 
  Очистка          : viber-7.0.0.1035-2.x86_64                                                                                                                     2/2 
  Запуск скриптлета: viber-7.0.0.1035-2.x86_64                                                                                                                     2/2 
  Проверка         : viber-12.0.0.7-2.x86_64                                                                                                                       1/2 
  Проверка         : viber-7.0.0.1035-2.x86_64                                                                                                                     2/2 

Обновлен:
  viber-12.0.0.7-2.x86_64                                                                                                                                              

Выполнено!
4. После перезапуска это - 12.0.0:
v2.png
(только отдельным окном теперь это скриншотить не даёт ;-) )

Аватара пользователя
Olej
Писатель
Сообщения: 12810
Зарегистрирован: 24 сен 2011, 14:22
Откуда: Харьков
Контактная информация:

Re: Viber

Непрочитанное сообщение Olej » 03 дек 2019, 17:02

Olej писал(а):
03 дек 2019, 16:13
Что характерно ... что в весьма свежей Fedora 30 - происходит следующее:
Но с Debian 10 всё та же история:

Код: Выделить всё

olej@ACER:~/Загрузки/Messanger$ sudo dpkg -i viber.2.deb 
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 415212 файлов и каталогов.)
Подготовка к распаковке viber.2.deb …
chown: невозможно получить доступ к '/home/olej/Documents/ViberDownloads': Нет такого файла или каталога
Распаковывается viber (12.0.0.7) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для mime-support (3.62) …
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber
Приложение версии 12.0.0.7 (как видим это по инсталляции) требует всё ту же устаревшую библиотеку из пакета libssl1.0.0.

Ответить

Вернуться в «Интернет и коммуниации»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость