Форум по операционной системе GNU/Linux и свободному программному обеспечению
Текущее время: 19 мар 2019, 05:28

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 33 ]  На страницу Пред.  1, 2, 3, 4
Автор Сообщение
 Заголовок сообщения: Re: Viber
Непрочитанное сообщениеДобавлено: 21 сен 2018, 12:46 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 11633
Откуда: Харьков
ypan49 писал(а):
Свежая публикация от 14-го сентября 2018г. по этому вопросу "Решение проблемы установки Viber в Ubuntu 18.04 LTS Bionic Beaver" здесь http://compizomania.blogspot.com/2018/0 ... eaver.html
Мне бы надо и телефон симитировать на компьютере (нету), чтоб без телефона и в Вабере и чтоб не в виртуальной машине, а в текущей операционке.

Из вашей ссылки самое интересное :-( важное вот это:
Цитата:
Одним из самых популярных мессенджеров в мире считается Viber, но, к сожалению, нынешний его владелец Rakuten Viber прекратил его разработку и поддержку под Linux.

После отказа от дальнейшей разработки около года назад, последней версией Viber под Linux является версия 7.0.0.1035, которая пока ещё доступна для скачивания на сайте мессенджера.

Что более понятно по-русски можно пересказать так: теперь от Viber десктопа под Linux следует отказаться и забыть. :cry:
P.S. ... а может и просто "отказаться и забыть" от Viber в сравнении с Telegram и WhatApps? ;-)


Вернуться к началу
 Профиль Отправить личное сообщение Отправить email  
 
 Заголовок сообщения: Re: Viber
Непрочитанное сообщениеДобавлено: 28 янв 2019, 10:48 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 11633
Откуда: Харьков
Olej писал(а):
Цитата:
После отказа от дальнейшей разработки около года назад, последней версией Viber под Linux является версия 7.0.0.1035, которая пока ещё доступна для скачивания на сайте мессенджера.

Что более понятно по-русски можно пересказать так: теперь от Viber десктопа под Linux следует отказаться и забыть. :cry:
P.S. ... а может и просто "отказаться и забыть" от Viber в сравнении с Telegram и WhatApps? ;-)

В новых инсталляциях некоторых дистрибутивов эту "остаточную" версию Viber под Linux уже и установить нельзя (версии библиотек и зависимости):
Код:
olej@ACER:~/Загрузки/Messanger$ lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux buster/sid
Release:   testing
Codename:   buster

Код:
olej@ACER:~/Загрузки/Messanger$ sudo dpkg -i viber.deb
[sudo] пароль для olej:
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 373708 файлов и каталогов.)
Подготовка к распаковке viber.deb …
Распаковывается viber (7.0.0.1035) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.
 viber зависит от libcurl3, однако:
  Пакет libcurl3 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-4) …
Обрабатываются триггеры для mime-support (3.61) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber

Код:
olej@ACER:~/Загрузки/Messanger$ sudo apt install libcurl3-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «libcurl3-dev» выбирается «libcurl4-openssl-dev»
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt --fix-broken install».
Следующие пакеты имеют неудовлетворённые зависимости:
 viber : Зависит: libssl1.0.0 но он не может быть установлен
         Зависит: libcurl3 но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).


Вернуться к началу
 Профиль Отправить личное сообщение Отправить email  
 
 Заголовок сообщения: Re: Viber
Непрочитанное сообщениеДобавлено: 15 мар 2019, 20:58 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 11633
Откуда: Харьков
Olej писал(а):
В новых инсталляциях некоторых дистрибутивов эту "остаточную" версию Viber под Linux уже и установить нельзя (версии библиотек и зависимости):

Её новости :-( ... После некоторого обновления Mint 19:
Код:
olej@nvidia:~$ lsb_release -a
No LSB modules are available.
Distributor ID:   LinuxMint
Description:   Linux Mint 19.1 Tessa
Release:   19.1
Codename:   tessa

Тот Viber, который ещё недавно работал (и который был установлен в какие-то баснословные времена ... когда Mint обновлялся 18.1 -> 18.2 -> 18.3 -> 19 ...) работать перестал:
Код:
olej@nvidia:~$ /opt/viber/Viber
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
QGLXContext: Failed to create dummy context
qml: type=""
failed to acquire GL context to resolve capabilities, using defaults..
qml: type=""
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
Аварийный останов

И попытка переустановки:
Код:
olej@nvidia:~$ apt search viber
i   viber                                                                - Free Text & Calls.                                                           

olej@nvidia:~$ sudo apt reinstall viber
W: Package viber had been marked to reinstall, but the file for the current installed version 7.0.0.1035 is not available
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
  viber
Следующие пакеты будут УДАЛЕНЫ:
  linux-modules-extra-4.15.0-43-generic{u}
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
E: Невозможно найти источник для загрузки «viber:amd64» версии «7.0.0.1035»
После распаковки освободится 171 MБ.
Хотите продолжить? [Y/n/?] y
E: Невозможно найти источник для загрузки «viber:amd64» версии «7.0.0.1035»
E: Внутренняя ошибка: не удалось создать список пакетов для скачивания
E: Perhaps the package lists are out of date, please try 'aptitude update' (or equivalent); otherwise some packages or versions are not available from the current repository sources

И так будет, естественно, со всеми существующими инсталляциями: библиотеки (OpenGL и др.) обновляются, а застывший Viber опирается на поддержку прежних версий... :-(


Вернуться к началу
 Профиль Отправить личное сообщение Отправить email  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 33 ]  На страницу Пред.  1, 2, 3, 4

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
[ Time : 0.119s | 17 Queries | GZIP : On ]